Trouble getting KQ games to run on Windows XP

HOME Forums King’s Quest Series Trouble getting KQ games to run on Windows XP

Viewing 6 reply threads
  • Author
    • #23116 Reply

      I have the King’s Quest Collector’s Edition that features the games from I-VI and I just can’t get it to run on my computer:( I can’t even install the games at all, no matter what I click on I just get the error messages “C:\Windows\System32/autoexec.nt. The system file is not compatible with MS-Dos and Windows programs. Select Close to shut down this application” or “D:\install.scr is not a valid Win32 program”!!! KQ is my favourite game series ever and although I do enjoy playing the AGD remakes I want to play the original games as well. I also have KQV on a cd-rom and I get the same trouble with that. I have tried installing the MultiResolution program, changed compatability to 640×480 and 16bit and I’ve changed compatabillity mode to Win 95, Win 98/2000 and so on. In short, I’ve tried everything. Oh yes, I have also installed Dos Box and it still doesn’t work.

      Also I have KQVII and that has always worked wonders, even on this PC. Only now that doesn’t seem to be the case anymore:( It is installed and I’ve played it on this computer before, but now I get the same error message that I mentioned above with this game too!!!! The only KQ game I seem to be able to run is KQVIII.

      Please help me someone

    • #23117 Reply

      There are several things you could try. I’ll just copy paste my solution from the AG forum =) 

      MS-DOS or 16-bit Windows-based program Error Message

      This installation program will reinstall the missing or corrupt Windows XP system files, autoexec.nt and config.nt. The absence or corruption of one or more of these files causes a “16 Bit Subsystem” error.

      XP_Fix.EXE by TRF Systems, Inc. 

      Problems from other users:

      Running Audit on my computer showed that a program called WINDUPDATE.EXE (not WINUPDATE.EXE) was deleting my Autoexec.nt file on boot up. If I replaced the file it would delete it again.
      Go to \Program Files\WINDUPDATE folder and delete it!

      Go to your registry and delete anything named WINDUPDATE. Put the Autoexec.nt file back into your \system32 folder and all is well! This was definately the
      problem here and I bet most everyone has the same nasty bugger, WINDUPDATE.EXE on their infected computer.

      Another note and workaround:

      C:\Windows\System32\Autoexec.nt The system file is not suitable for running MS-DOS and Microsoft Windows applications. Choose ‘Close’ to terminate the application.

      This problem just started around mid August 2004, so I suspect it to be related to a recent Microsoft Update that you may have downloaded for Windows XP.

      HomeSchool Easy Records (the current version) is a Windows program (not a DOS program) but it is a “16 bit” Windows program. Apparently HER and other 16 bit Windows programs will run into this error when you try to run them. Note: HER version 3, now in the works, is a 32 bit Windows program, so it won’t be prone to this problem.

      There is a cure. Please read the following tip and follow the steps to reinstall three files: autoexec.nt, config.nt, and

      Side note: You also want to look for the file “windupdate.exe” (note the spelling closely — the ‘d’) and if you find it anywhere on your hard drive, delete it! This is a secondary problem and you are not very likely to find this file. But if you have it, it actually deletes the autoexec.nt file each time you start your PC, so even if you restore the file, it will get deleted again!

      Here is the tip originally posted to the Internet by Spencer Greystrong:

      This article…kb;en-us;324767  is the Microsoft response to that error message. The fix involves expanding the original files from your XP CD and overwriting. The problem with that solution is that many people do not have the original CD. [So the links below were created so you can get the files directly].

      When you click on either link below you will see a file-download window appear. Click on the “Open” button and you will get a WinZip self-extractor window. Leave the “Unzip to folder” set to “cwindows\system32” and leave the “Overwrite files without prompting” check box checked. Ignore the yellow warning sign (this is trustworthy code). Click on the “Unzip” button. The files will save to your hard drive. Then click on the “Close” button.

      For Windows XP Professional click on this link:…/XPProfiles.exe 
      windupdate.exe is spyware and will read as: DPF: {15AD4789-CDB4-47E1-A9DA-992EE8E6BAD6} –…0f91b20c15a3e0e 

      Hope this helps

    • #23118 Reply

      Alternatively, get rid of the windupdate.exe file if it exists and then replace either your existing autoexec.nt or copy this to where it should go: 

      – Alistair

    • #23119 Reply

      Thanks ever so much….now they run without problems 🙂 But now there’s another thing that I can’t get to work though. I had to buy KQVII again due to a bad crack in the CD and I can install it, but not get it to run 🙁 I get an application error message which reads: “The instruction at 00000000 referenced memory at 00000000. The memory could not be read from. Click on OK to terminate the application.”
      And whenever I try to run the Setup configuration test to see if my computer meets the required settings I get an error message when trying to test the speed at my cd rom, saying “integer divide by 0”. I don’t get this, does anyone know what I can do to make it work??? Or was it just a waste of money????

    • #23120 Reply

      i have a problem a bit like that. i have KQC on cd and i tried installing KQ6 it installed but didn’t run. it went blck for 1/2 a sec and quit back to the dektop. i tried the compatibility settings but that didn’t help. anyone know how to fix this

    • #23121 Reply

      About the divide 0 problem… You know you can skip the compatibility tests! The setup asks you if you really want to skip the tests or something and then continues with the installation. Just try it. So you didn’t waste your money 😉

      About King’s Quest 6…
      Did you try to use another resolution? 800*600 or even lower? Also try to use the 256 Color option instead of 16 or 32 Bit.

      Hope this helps 😉

    • #23122 Reply

      [Updated] I have an email from Sierra support that stated that the “divide by zero” error can be corrected by deleting the sierra.ini file. They stated that some of the old programs like mine did not recognize the newer processors. Attached is the email from tech support.

      Sierra Support Email

Viewing 6 reply threads
Reply To: Trouble getting KQ games to run on Windows XP
Your information: