Help me please, I’m desperate!

HOME Forums Bugs / Tech Help Help me please, I’m desperate!

Viewing 6 reply threads
  • Author
    • #23665 Reply

      Help me out here please!

      I am by far a “newbie” to the realm of Sierra Gaming. Indeed, I even played all but one of the original King’s Quest games on their original instillations…I remember playing King’s Quest on floppy discs and the following games on 3.5 discs. But now I’ve got a problem, and I could use some advice on how to solve it.

      The situation is that I ordered Space Quest IV off of ebay. Yea, I know we’re not exactly dealing with Roberta’s work here, but I figured this was the best place to come and ask for help.

      I got the game, and it had no manual, game only. No manual is fine, I can deal with that, that’s what online walk-throughts and hint sites are for. The problem I have is two-fold :

      1) The game seems to work just fine. But every time Roger Wilco walks into a new room the entire room — not the full screen as in my entire computer screen, but the “room” Roger is in – is completely black, except for where Roger stands. Nothing shows up until he walks to a certain spot, then everywhere he’s been shows up. It’s like there’s a little rectangle around him and anywhere he goes that rectangle moves the darkness out of the way. I *know* this isn’t the way the game is supposed to be played, because I’ve read enough websites on it to have discovered that.

      It’s really bugging me, so what I need to know is how can I prevent that? Right now the only solution I have found is to minimize the window that holds the game then maximize it again, and everything is cleared up, no black anywhere. BUT due to the nature of this game, that being that robotic droids and cyber-zombies are roaming in adjoining rooms at random, these precious few seconds where I have to minimize/maximize to see what I’m doing keeps getting me KILLED! So how can I fix this so that this annoying blackness is gone completely? Should have known something was up when the introduction had squares appearing around Roger that didn’t seem to serve any graphical purpose.

      2) How the heck can I uninstall this game? I am checking all files on the CD but it doesn’t tell me anything I need to know, nor do I see an ‘uninstall’ file. I was thinking if maybe I played from just the CD rather than the hard drive this ‘blind-man’s-bluff’ I keep having to play will cease but I haven’t tried that yet, since it’s a last ditch effort for now. What I wanted to do BEFORE I tried that was to uninstall the game then play it from the CD with no files on the hard drive – but I can’t seem to find anything programmed into the CD that uninstalls the game. Yea, yea, I know, if I was really as good as I say I am I wouldn’t have to worry about that since all I’d have to do is to go into my computer itself and find a program that allows me to uninstall items. Which I’m about to do. But barring taking that action, does the CD have anything that uninstalls?

      After I type this I’m going to try to manually uninstall it using my computer and then see if I can play from just the CD, which is an option given once the game loads through several files. But I’d *really* like it so that this blackness never occurs at all!

      I’m guessing it’s my computer having a conflict with the way the graphics were originally programmed, and if I don’t want something that makes it look like Roger keeps playing peek-a-boo with the interface that I’ll have to buy the block of Space Quest games that come with all of them, sans Roger’s jockstrap. But, is it my computer having a problem with the way Roger looks or is it something as simple as modifying the game settings themselves?

      Please assist me here, I don’t think I got screwed on the deal for this ebay auction as the game itself seems to play just fine. I see that damn annoying Energizer Bunny just fine, the robots that keep killing me show up okay, and everything else seems to be in place, including the voice of an omnipotent Gary Owens. But since I haven’t left feedback on ebay yet I need to know what’s going on here, and what can I do about it?

      Thanks for reading this far, and may the spirit of Sierra live on! I’m seriously considering purchasing that Hobbit game I saw at Wal-Mart that’s running $29.95 at the moment.

    • #23666 Reply

      (re: Help me please, I’m desperate!)

      First off, Do yourself a favor and DO NOT buy the Hobbit game…

      That said, to un-install the game, just delete the “SQ4” folder from your Sierra directory.

      Then try isntalling again. (Most likely futile, maybe 256 color mode would help?)

      Beyond that, I will need to know what type of system you are using. More to the point, what operating system, video card, etc. Then I am sure there are many others here who can offer you support on a newer system.

      Good luck and most of all WELCOME HOME 🙂

    • #23667 Reply

      (re: Help me please, I’m desperate!)

      Thanks for the advice, I selected it to run in 256k colors and that got the problem solved. I have, however, all but given up on the game because I cannot get that goddamn laptop out of the busted spaceship and walk off screen again before being zapped by the droid. It is far too frustrating to deal with, and I simply don’t want to bother anymore.

      I don’t see why they bothered to make Space Quest IV when it is by far the most frustrating and problem-filled of the games.

    • #23668 Reply

      (re: Help me please, I’m desperate!)


      Never stop playing Space Quest IV as it’s really one of the best old classics, the solution to ALL your problems is so simple:

      1. Download DOSBox. 

      2. Install DOSBox.

      3. Launch DOSBox.

      4. A black window with some text will appear. Type the following in it:

      Mount C C:\Sierra (then press enter)

      In what’s written above I assumed that you install the game to the directory/folder C:\SIERRA, if for example you installed it to D:\SQ4 then you should type:

      Mount C D:\SQ4

      Other examples:

      Mount C C:\Sierra\SQ4
      Mount C C:\SQ4
      Mount C D:\Sierra\SQ4-CD
      etc …

      Once you typed the correct statement continue reading.

      5. Type:

      C: (then press enter)

      6. Type:

      Sierra (then press enter)

      7. That’s it, this will solve ALL the problems, and it works.

      If you have any questions let me know, and by the way, you should be using DOSBox for ALL sierra adventure games in order to have them work with no problems at all.


    • #23669 Reply

      (re: re: Help me please, I’m desperate!)

      Rani, what is DOSBox and what exactly does it do?

      As for “never stop playing SQ4,” I’m afraid I’ve done just that. I can’t get the laptop out of the glove compartment of the crashed shuttlecraft because by the time I have it in inventory, I’m dead via the “Droid-o-Death.” The interface is simply not set up to where I can run in and use the hand tool repeatedly to click on the glove compartment, open it up, grab the laptop and THEN switch to the ‘walk’ icon in time to walk off-screen. I simply can’t do it, I keep getting zapped, and the Droid shows up EVERY time. The problem is that the interface is a piece of…well, you know. If I try to manually click with the mouse to move from Hand to Walk icon, by the time I’ve got it, I’m dead. If I try to move the mouse to the top part of the screen and select the Walk icon from the drop-down menu, I’m still dead.

      I know there’s a solution but I don’t care to find it. Space Quest IV is far too much trouble for me, I’m giving up.

    • #23670 Reply

      (re: re: re: Help me please, I’m desperate!) I guess could call DOSBox a DOS virtual machine. That is to say it emulates an entire DOS based PC including the CPU, sound and video. There’s even a recent provision of an Epson based dot matrix printer!
      It’s constantly evolving and improving with the most recent versions able to play 32bit protected mode titles. It needs a powerful host to be able to run some of the more complex titles.
      More details can be found at their site :

      If you like your games to be 1) insert disc 2) play then don’t bother looking at DOSBox. Having read your unwarranted rant about SQIV and the [well-known] timer issue and your resolution to just give up I don’t think DOSBox will suit you. However, it’s a real gem of a tool and if you take the time to understand it, a few minutes tweaking per game can provide you with many hours of ‘retro’ gaming!

    • #23671 Reply

      (re: Help me please, I’m desperate!)

      Yes, Space Quest IV is my favorite as well. Such as shame to quit because of that issue!

Viewing 6 reply threads
Reply To: Help me please, I’m desperate!
Your information: